Benutzer-Werkzeuge

Webseiten-Werkzeuge


Seitenleiste

pc:qcanobserver

Compiling QCANObserver on Ubuntu 12.04

Prerequisites

Install the QT4 development packages, where qtcreator itself is not needed, but it helps to install the whole environment

sudo apt-get install libqwt5-qt4-dev libqwt5-qt4 qtcreator 

Download & compile the QCANObserver Code

svn co https://qcanobserver.svn.sourceforge.net/svnroot/qcanobserver qcanobserver
cd qcanobserver
qmake

After running qmake as above, make a few tweaks in the generated makefile:

In the parameter „INCPATH =“ change

-I/usr/include/qwt5

to

-I/usr/include/qwt-qt4

and in „LIBS =“ change

-lqwt

to

-lqwt-qt4

Then run

make

Compiling the socket driver

cd  DeviceLib/linux/SocketCAN
qmake
make
cp libSocketCAN.so ../../../lib/

Run QCANObserver

change into the QCANObserver directory and just start the program

./QCanObserver
pc/qcanobserver.txt · Zuletzt geändert: 2013/04/06 09:21 von admin